Ada sesetengah pengguna Archbang menghadapi masalah masa nak install Catalyst driver sebab Archbang dah di-ship dengan drivernya sendiri lalu mengalami masalah dependency. Biasanya kuar macam ni:

:: catalyst-utils and libgl are in conflict. Remove libgl? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: ati-dri: requires libgl=7.11.2
:: intel-dri: requires libgl=7.11.2
:: mach64-dri: requires libgl=7.11.2
:: mga-dri: requires libgl=7.11.2
:: r128-dri: requires libgl=7.11.2
:: savage-dri: requires libgl=7.11.2
:: sis-dri: requires libgl=7.11.2
:: tdfx-dri: requires libgl=7.11.2
Dependencies for `catalyst’ are not met, not building…

Ok, cuba remove semua berkenaan dengan ATi yang diship oleh Archbang. Macam ni

sudo pacman -Rscn xf86-video-apm xf86-video-ark xf86-video-ast xf86-video-ati xf86-video-chips xf86-video-cirrus xf86-video-dummy xf86-video-fbdev xf86-video-glint xf86-video-i128 xf86-video-i740 xf86-video-intel xf86-video-mach64 xf86-video-mga xf86-video-neomagic xf86-video-nv xf86-video-r128 xf86-video-rendition xf86-video-s3 xf86-video-s3virge xf86-video-savage xf86-video-siliconmotion xf86-video-sis xf86-video-sisusb xf86-video-tdfx xf86-video-trident xf86-video-tseng xf86-video-v4l xf86-video-vesa xf86-video-vmware xf86-video-voodoo xf86-video-xgi xf86-video-xgixp ati-dri intel-dri mach64-dri mga-dri r128-dri savage-dri sis-dri tdfx-dri

Kemudian add repo

[xorg111]
Server = http://catalyst.apocalypsus.net/repo/xorg111/$arch

above all repositories in /etc/pacman.conf dan downgrade xorg.. Takpe, takde effect kat sistem.

pacman -Syuu

sekarang boleh install Catalyst macam biasa 😉

Good luck.

Advertisements